对微软的最新操作系统Windows 7来说,它现在是否已经能够完美的支持即将取代IPv4的IPV6地址呢, z/ T3 q0 J& o1 Z
各种信息显示,和互联网息息相关的IPv4地址的“剩余油量指示灯”正闪烁着即将耗尽的警告,IPv4地址只剩下5%的数量可用了,预计到明年的秋 天就将彻底耗尽。对微软的最新操作系统Windows 7来说,它现在是否已经能够完美的支持即将取代IPv4的IPV6地址呢?7 U9 D% O/ [* \- p
事实上,与以前的那些操作系统相比,Windows 7操作系统已经在支持IPV6协议上做出了很好了;但是,仍然有一些瑕疵。
$ I4 M" \) I( h8 t6 v% J 首先想到的一个问题是在Windows Server 2008 和 Windows 7操作系统中配置IPV6协议地址时采用的都还是随机接口标识。虽然Windows 7操作系统已经证明为IPV6做好了准备,但是和预定的目标还是有那么点差别。
( d* ]1 p: Z* B IPV6地址的设定是不应该采取这种方式的。事实上,一个IPV6地址设备应该应用NDP(邻居发现协议)来确定它的网络状况和接口标识并自动 的配置出128位IPV6 地址。关于IPV6协议分配的相关规定,在IETF(互联网工程任务组)给出的文件中有详细说明,文件包括:0 [8 S. l& ?. ~9 @, o! \
IETF RFC 2373(IPV6寻址体系架构)
3 W+ \" a/ a8 q: d1 v IETF RFC 2464(IPV6协议数据包在以太网上传输)# @) Y6 z% R0 B: ~0 @8 r/ W
RFC 4941(IPV6中无状态地址自动配置的保密性扩展)2 S2 {7 y) l7 O5 v& G- T
微软在接口标识应该如何产生的问题上似乎有些混乱,尽管微软的雨林木风装机版工程师们在RFC 4941的书写过程中提供过帮助。当然,你仍然可以强迫你的Windows 7操作系统采用正确的IPV6地址配置方法,通过在DOS界面中运行如下的命令即可:, y; D( ~; _2 X) p; s2 ?
netsh interface IPV6 set global randomizeidentifiers=disabled
: L9 v! `# J( y$ z7 b) M5 U% \3 u 建议你将这些命令放到批处理文件或登录文件中,以实现每次启动Windows 7时自动运行上面的命令。这么做能让你避免与其他的Windows 7系统或支持IPV6的网络设备如思科公司的Catalyst交换机等出现一些与IPV6协议相关的问题。
7 B. |" y! C5 ?7 M 如果Windows 7能支持SEND安全邻居发现协议(RFC 3971),那情况就很不错了。SEND是NDP的更安全的版本。应用SEND,你可以验证在你局域网中的设备是否安全有效。
3 G( ]. X' i- Q; a( P5 a& x" ^1 Q 不幸的是,尽管微软也在书写SEND这一规范的过程中提供过帮助,但是Windows 7依旧萝卜家园没在系统中将其实现。而一些主要的网络设备供应商,如思科和Juniper网络公司,已经实现了对SEND的支持。希望微软能在下一次发布的服务补 丁包中,在其所有的操作系统中实现对SEND的支持,同时也包括前面提到的正确的IPV6地址配置方法的实现。毕竟,面对IPv4协议地址上的危机,更早 的消除和IPV6协议地址相关的潜在的实施问题和安全担忧,会更好。6 O; O3 [7 s& e
. s( D+ t$ _8 y& Z, o! _ |